Changeset 909


Ignore:
Timestamp:
Apr 28, 2011, 3:21:46 PM (8 years ago)
Author:
gav
Message:

Install class-diagram plugin in branches/util-apps/DomainUtil.

Location:
branches/util-apps/DomainUtil/grails-app
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • branches/util-apps/DomainUtil/grails-app/conf/BuildConfig.groovy

    r907 r909  
    2424        //mavenRepo "http://repository.jboss.com/maven2/"
    2525    }
     26    plugins {
     27        runtime ':class-diagram:0.5.2'
     28    }
    2629    dependencies {
    2730        // specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes eg.
  • branches/util-apps/DomainUtil/grails-app/views/index.gsp

    r907 r909  
    9696                </ul>
    9797            </div>
     98
     99            <div id="classDiagramList" class="dialog">
     100                <h2>Entity Relationship Diagram:</h2>
     101                <ul>
     102                    <a href="${createLink(controller:'classDiagram',
     103                                action:'model',
     104                                params:[outputFormat: 'pdf',
     105                                skin: 'classicSpaced',
     106                                showMethods: 'false', autoUpdate: 'false'])}">PDF</a>
     107                </ul>
     108                <ul>
     109                    <a href="${createLink(controller:'classDiagram',
     110                                action:'legend',
     111                                target:'_blank')}">Legend</a>
     112                </ul>
     113                <ul>
     114                    <a href="${createLink(controller:'classDiagram',
     115                                action:'show')}">Interactive.</a>
     116                </ul>
     117            </div>
     118
    98119        </div>
    99120    </body>
Note: See TracChangeset for help on using the changeset viewer.